无法安装hype-v:虚拟机监控程序已在运行中,

最近闲得慌想去考个MCSE的SERVER2012,看教程实验过程中遇到了很多问题,想起以前有把这些问题和解决方案记录到博客的习惯,重新拾起来吧。

这次遇到的问题是因为在VMWARE中安装了server2012后,再安装Hyper-v时提示无法安装hype-v 虚拟机监控程序已在运行中,于是百度到此篇文章,转载过来以做记录。

相信很多同学遇到过这样的问题,在学习Hyper-v过程中由于没有2台以上的实体机而无法复制、迁移等实验。下面实验教大家怎么在VMware 中安装Hyper-v。

1.在虚拟机设置中,CPU属性中勾选“Virtualize Intel VT-x/EPT or AMD-V/RVI”来启用虚拟机的CPU支持虚拟化。

image

2.在虚拟机文件所在目录中找到 .vmx文件。

image

3.用记事本打开该 .vmx文件,然后在末尾下面增加2个参数。

hypervisor.cpuid.v0 = “FALSE” 

mce.enable = “TRUE”

image

注:如果没有添加这2个参数是无法安装Hyper-V的,会出现如下错误

发表评论

电子邮件地址不会被公开。